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Getting Started

Installing Visual Paradigm
1. Execute the Visual Paradigm installer.
e—— Visual_Paradigm_13_1_20160418_Wi

Q_‘ ned.exe L\\’

Visual Paradigm 13.1

2. Click Next to proceed to the License Agreement page.

3. Read through the license agreement. If you fully understand and agree with them, choose | accept the
agreement to accept the terms. Click Next.

4. Specify the directory for installing Visual Paradigm. Click Next to continue.

5. Specify the name of the Start Menu folder that will be used to store the shortcuts. Keep Create shortcuts
for all users checked if you want the shortcut(s) to be available in all the user accounts in the machine.
Click Next to continue.

6. Inthe Select File Associations page, keep Visual Paradigm Project (*.vpp) checked if you want your
system to be able to open the project file upon direct execution (i.e. double click). Click Next to start the
file copying process.

7. Once thefile copying is finished, you can choose to start Visual Paradigm immediately. On the other hand,
you can finish the installation without starting Visual Paradigm. Choose the option Don't Start and click
Finish. This ends the installation of Visual Paradigm.

Starting Visual Paradigm

Windows users can start Visual Paradigm via the Start screen (for Windows 8/8.1/10) or Start

@ A menu (for Windows 7 or earlier). If you selected not to create an entry in the Start menu (during
the installation), you can look under the installation folder of Visual Paradigm (the same path

specified in step 4 in the section above) and start Visual Paradigm by running Visual

\ﬁsual Paradigm
131 Paradigm.exe in the bin folder.

Selecting License Type
When you start Visual Paradigm the first time, you are asked to select a way to activate Visual Paradigm.
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Thank you for installing
Visual Paradigm

Please select license type

30 Days FREE
Evaluation

Perpetual License Subscription /

*_ The license of Visual Paradigm with no Academic License
expiration date.

Subscribe Wisual Paradigm for a period of
time, or as a qualified academic partner.

Contact Support Team Exit

Depending on whether you own a purchased copy or an evaluation copy of Visual Paradigm, you can proceed by
following the steps below respectively:

For Customers

You should receive a notification Email with an activation code. The same activation code can also be found from
the license key listed in your customer account. Copy the activation code first, click on Perpetual License, paste the
copied activation code and then click Activate to continue.

For Evaluation
If you want to evaluate Visual Paradigm, click 30 Days FREE Evaluation to start your 30 days evaluation.
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The Environment

Project | UeXceler  Diagram  View  Team  Tools  Modelng  Window  Help

TEMEMR @7 @ B (1)

o, tmport
New Save  Close | Print Referenced | Properties
@ - @ Project

Welcome to Visual Paradigm 9

Manage Requirements Design
* Manage requirements with the UX tools provided with UeXceler. * Visualze business workflow using business process diagram (BPD).
* Visualze high level user goals with a use case diagram. * Design different aspects of IT systems with different UML diagrams.
* Capture and eleborate stakeholders' needs with user stories. * Design database with Entity Relationship Diagram (ERD).
* Use storyboard and wireframes to visualze user experience. * Visualze user experience with storyboard and wireframes.

* Attach design artifacts and reference files to user stories.
* Plan and prioritize user stories in sprint.

Checkout Project Sample Projects
. Sample projects are provided to showcase the usage
Checkout your project from VPository.com and start A
@ working collboratively with your team. of Visual Paradigm in visual modeing and v

ranniramanty rinn
= B

No. Name Description
1 Toolbar A tabbed toolbar that allows you to perform various operations in Visual
Paradigm.
2 Diagram editor The diagram will be displayed in diagram editor.
3 Status bar Notifications are shown here. You can also open the message pane and

description pane from the bottom right of the status bar.

Saving and Opening Project
To save your work, select either Project > Save or Project > Save as.... When you are saving a project for the first
time, you will be asked to specify its location.

To open an existing project, select Project > Open from the toolbar and select the project to open.
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Basic Diagramming Techniques

This section will go through the steps of creating diagrams, creating shapes and connecting them. You will also
learn how to document model elements and make diagrams more readable by coloring shapes.

Creating Diagram
Let’s take use case diagram as an example. To create a use case diagram:

1.
2.

s

Select Diagram > New from the toolbar.

At the top of the New Diagram window, enter
the diagram type (or a part of it).

Select the type of diagram to create.

Click Next.

Enter the diagram name, its location and
description.

Click OK.

Creating and Connecting Shapes
Using the diagram toolbar

Let’s create an actor from the diagram toolbar for now.

1.
2.

Click on Actor in the diagram toolbar.
Click on the diagram to create an actor, and
enter its name.

Click on the diagram or press Enter to confirm.

Using the Resource Catalog
If you move your mouse pointer over a shape, you will an icon at its top right corner. The icon is for you to access
the Resource Catalog.

¢

New Diagram

Use|

L3

Use Case Diagram

Model the stakeholders of a system as well as the goals that they want to
achieve through interacting with the system.

Activity Diagram
Model the workflow within a system with the use of activity, action, decision,

etc.

Business Process Diagram
Model business workflow with the use of OMG BPMN (Business Process Mode!

and Notation).

%)3

)

Customer

Resource Catalog allows you to create a new shape that connects with an existing one. You can also use it to create
connector between two shapes. Let’s create a use case from actor.

1.

Move your mouse pointer over the
actor shape.

Press on the Resource Catalog
button and drag to the right.

Release the mouse button and select
Association -> Use Case from
Resource Catalog.

Enter the name of use case. This will
create a use case that associates with
the actor.

Customer

o
—

Customer

o ” A e
Ed 5 LA™ Customer K% ®. .
Customer 2 B

Association -> Use Case
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Resizing Shape

When you click on a shape, you will see several resize handlers appear . i
around the shape. You can drag on these handlers to enlarge or diminish - S
the shape. Ty

Customer

Adding Control Points to Connector

For most diagram types, ‘oblique connector’ is chosen as the default connector type, meaning that when you draw
a connector, it will be an oblique connector. To route such connector, you can add control points to it. To add
control points, simply drag on the connector to create a point, and then keep dragging to adjust its position.

Edit Order

Customer

!
i

Cancel Order
s

" 4 There are totally five connector types. If you want to apply another connector type on a connector,
right click on that connector and select Styles and Formatting > Connector Styles > [TYPE] from the
popup menu. If you want to update all the connectors in a diagram, right click on the background of
diagram and select Connectors > [TYPE] from the popup menu.

Describing Model Element

Generally speaking, naming model elements alone would not suffice to describe their details. To elaborate, you
can enter additional details in the Description Pane. Simply go to the diagram and select the shape you need to
describe. Click on the Show Description button at the bottom right of the status bar to open the Description Pane
and fill in the details.

In addition to textual description, voice recording is also available. If your machine supports microphone usage,
click the Record button at the top right of the Description Pane. In the Record Voice window, click the red circle
button to start recording. To stop, click the button with a square inside. To save your recording, click OK.

" 4 Make sure your recording device is available when applying this feature.

Editing Shape Color
Make your diagram more expressive by formatting shapes based on their contexts. Let’s change the color of a use
case shape.

1. Right click on the use case shape and select Styles and Colar: [ sreen

Formatting > Formats... from the popup menu. = B:ﬂck o
Blue
2. Open the Background tab in the Formats window. Select =] cyen
Green for color. Click OK to confirm the change. I Drkoay
[ Gray

[ Light gray k

I Magenta

[ crange

[ Pink

[ Red

[ white ¥
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UML Modeling

Use Case Diagram
A use case diagram is used to model and identify the functional requirements of a software system. In a use case
diagram, stakeholders and user goals are represented by actor and use cases respectively.

Place Order

Edit Order
Cancel Order

An actor is any person or external system that interacts with the system to achieve a user goal (i.e. use case). The
use case diagram above illustrates the use cases of an order processing system. Customer, an actor, interacts with
the system to accomplish the goal of order placement, as modeled by the use case Place Order. There are other
goals that the customer wants to accomplish, such as Edit Order and Cancel Order. You can apply the diagramming
techniques described in the previous section to create such diagram.

Customer

Sequence Diagram
A sequence diagram is primarily used to show the interaction between objects that are represented as lifelines in a
sequential order. More importantly, lifelines show all of their interaction points with other objects in events.

As always, you can create a new diagram via the toolbar, same for sequence diagram. To create sequence diagram,
choose Diagram > New from the toolbar. Then, select UML diagrams > Sequence Diagram in the New Diagram
window. Here, let’s create a sequence diagram with an alternative approach - create as a sub-diagram of use case.

The reason of creating a sequence diagram as a sub-diagram of use case is to visualize the interaction between
user and system in accomplishing the use case. Let’s see how it works. We will carry on with the use case diagram
created in the previous section.

1. Move your mouse pointer over the use case Cancel Order. . K e

2. Click on the tiny Sub Diagrams button at the bottom right of the shape Cancel Order
and select New Diagram... from the popup menu. S

3. This shows the New Diagram window. Select Sequence Diagram and New Diagrom. .
then click Next. Exiting Degram.

4. Click OK. .

5. This creates a blank sequence diagram. Create an actor Customer in . .
the diagram. You can find Actor from the diagram toolbar. CUSIOMEr | o s o o gy

6. Let’s model the interaction of how customer can cancel an order. - ],\6.’ A
Move the mouse pointer over the actor. Press on the Resource
Catalog button and drag it out.

7. Release the mouse button and select Message -> LifeLine from the . .

Resource Catalog.

8. Name the lifeline System, and the message login.

9. Complete the interaction by adding other messages and the Order
lifeline.
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System Problem Order

Customer

1: legin |
2: open order (id)
21! load
| .
g
3: click Cancel
3.1 close
>
T |
| |
(M ] ]
" 4 To go back to the parent use case, you can click on the shortcut on top of the diagram:
Cancel Order Cancel Order
n | U Customer

Activity Diagram

An activity diagram is essentially a flowchart, showing the flow of control from one activity to another. Unlike a
traditional flowchart, it can model the dynamic aspects of a system because it involves modeling the sequential
steps in a computational process. Let’s make use of an activity diagram to model the registration process.

1. Create an empty activity diagram named Registration. You can create an activity diagram by selecting
Diagram > New from the toolbar. Then, select Activity Diagram in the New Diagram window. Click Next
and then click OK.

2. Create a swimlane for grouping actions based on the participants. Select Horizontal Swimlane from the
diagram toolbar and click on the diagram to create one.

3. Double click on the headers and rename them to User and System, respectively.

User

System

4. Create initial nodes, actions, decision node and activity final node inside the swimlane. Do remember to
resize the swimlane to accommodate the shapes.

| @— [R:;:‘a] | "_"’_f:m“"" Clck [Submi] |——

Uscr

The decision node represents the moment where a decision has to be made. Multiple flows will be
produced based on different results of decision making.

" 4 The Control Flow -> Action resource helps you create action shapes rapidly.
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Class Diagram
A class diagram models the blueprints of objects required by a system and the relationships between them. Let’s
make use of class diagram to model the domain classes of the order processing system.

C payments Payment
-name : String 1.+ |-date:Date
-telephone : String -remarks . String
-address : String
+printCustomerDetails(delimiter : String) ﬁ
CreditC. C

Class Diagram and Package Header

When you create a class diagram, you are prompted to enter the package header (see the image below). Package
header is a quick way to create new class diagram in a package. The diagram and the shapes created in the
diagram will all be grouped by the package specified. Let’s say if you want the class diagram to be grouped by a
package mypackage, enter mypackage in package header.

Class Diagram1
19, mypackage|

By doing so, a new package will be created, with the new class diagram put inside. You

can inspect the structuring in the Model Structure view, opening by clicking ™ at the B
top rght of any agram.

mypackage

" 4 If the package you specified exists, the new class diagram will be put in
that existing package. If the specified package does not exist, a new
package will be created.

" 4 You may enter fully qualified name — for example,
com.example.mypackage. By doing so, multiple packages will be created
(if not exist), nested package hierarchy will be formed.

Attributes and Operations
Properties of a class are represented by attributes. To add an attribute:

Right click on a class and select Add > Attribute from the popup menu. Customer
Type the name and type of attribute inline - for example, name : String. jmﬂ:’gw n
Press Enter to confirm. | address:String|

You can now create the next attribute by repeating step 2. To stop, press Esc.

el

Features of a class are represented by operations. To add an operation:

1. Rightclick on a class and select Add > Operation from the popup menu.
2. Type the name and optionally the method signature (i.e. parameters and return =
. . .. . -name : Str
type) - for example, printCustomerDetails(delimiter : String). e fgm,_; L
3. Press Enter to confirm. -address : String
4. You can now create the next operation by repeating step 2. To stop, press Esc. . L

+printCustomerDetails(delimiter : Strin g}l
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Classes with Association
To associate two cIasses:

1.
2.
3.

4.

C

Move the mouse pointer over the source class.

-name : Sting

Press on the Resource Catalog button and drag it out.  |eiephone: String

-address : String

Select Association -> Class from the Resource Catalog

+printCustomerDetails(delimiter : String)

to create an associated class.
Name the class and press Enter.

To edit an association end, double-click on the end to open the Association Editor. Enter a name for the role of the
association in the middle text box and adjust properties like multiplicity and navigability as needed.

C

-name : String
-telephone : String -
-address : String

+printCustomerDetails(delimiter : String)

payments
1.7

Assodation End To

@ - ool

Payment

Role name : payments

Classes with Generalization
Generalization models “a-kind-of” relationship among classes. In Visual Paradigm, generalization can be created
easily via the resource-centric interface, from super-class to sub-class.

1.
2.
3.

Move the mouse pointer over the super class.

Press on the Resource Catalog button and drag it out.
Select Generalization -> Class from the Resource Catalog
class with generalization.

Name the sub-class and press Enter.

to create a sub-

payments

Payment

1.7

——

CreditC.

-~
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Business Process Modeling (with BPMN)

Business Process Diagram (BPD)

A Business Process Diagram (BPD) is used when you want to represent operational workflow. A BPD is mainly
composed of activity elements such as tasks and sub-processes. They both represent work that an organization
performs in a business process.

Here is a list of frequently-seen elements in a BPD:

O Start event Where the process begins and under what condition

Drive business flow based on the event it specifies. Intermediate event can
be attached to an activity for modeling an event that may happen during
O Intermediate event  the execution of that activity. It may also be connected by a connecting
object for modeling an event that may happen after the execution of the
flow element before.
O End event Indicate where a business process completes

Task Task Atomic work which cannot be further broken down.

Gateway The diagram will be displayed in diagram pane.

Sub-process Non-atomic, complex work that can be elaborated into smaller works

Let’s make use of BPD to model a parcel collection process.

1. Create an empty BPD named Parcel Collection. You can create a BPD by selecting Diagram > New from the
toolbar. Then, select Business Process Diagram in the New Diagram window. Click Next and then click
OK.

2. Create a pool for the post office officer, the person who execute the process. Select Horizontal Pool from
the diagram toolbar and click on the diagram to create one. Name the pool Post Office Officer.

3. Create start event, tasks, gateway and end event inside the pool.

Bring Parcel to CounterH Collect Payment ]—Do

Lookup Pamcel

Paost Office Officer

Working with Sub-Process

Converting Task to Sub-Process

When your business expanded, you may need to revise your business process design by including more details. In
such case, you may need to convert a task into a sub-process and to detail its workflow in another business
process diagram. To convert a task to a sub-process, right click on the desired task and select Convert to Sub-
Process from the popup menu.

Drilling-Down Sub-Process
A sub-process can be expanded to show a lower-level process. To expand a sub-process, click on
the “+” symbol at the bottom of the sub-process shape. By doing this, a new BPD will be opened.
B

L3
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You can then model the internal details using activities, gateways, events, etc. When you go back to the parent
level BPD, you will see the sub-level details appear in the sub-process shape.

Yes
Lockup Parcel Bring Parcel bCounterH Collect Payment ]—Do

Post Office Officer

" 4 To collapse an expanded sub-process shape, click “-” at its bottom. To expand it, click “+” again.

Documenting Working Procedure
The necessary procedure to handle a task/sub-process can be specified by filling in the operating procedure. To

specify working procedure of a task/sub-process, simply select the desired task/sub-process and enter the
procedure in the Procedure Editor below the diagram. If you don’t see the editor opened, right click on the
background of diagram and select Show Procedure Editor from the popup menu.

Analyze Tracking
Number

-

Procedure v \=|%|FE AV EE‘ h‘nﬂ
1. Read the 2nd and 3rd digit for verification
2. Read the last 4 digits for batch number
3. Check the log bool for status of batch arrival

Animating Business Process
When you present your business process design to someone, like your clients or manager, having a way to

visualize the workflow dynamically can help you expressing the design more effectively. Moreover, that’s what the
animation feature can help. The animation feature allows you to animate your design from the very first element,
which is typically the start event until the final element. To animate a BPD:

1. Right click on the background of BPD and select Show Animation Panel from the popup menu.
2. Click “+” at the top of the Animation Panel.

v ™|
g .

*
3. Enter the name of the path to animate — for example, Collect parcel (success).
4. If your process design contains gateway (or any other kinds of element for decision making), you may
need to construct the path manually.
- Farcel F‘_Eady?ﬂ
. © 0 <untitled >
]

Verify Tracking Mumber

@
5. Click ™ to play the path. Shapes have been passed by are highlighted in purple by default. And whenever
the animation is progressing through a sequence or message flow, a dark ball would appear and move
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along the line to guide your line of vision.

Lookup Parcel

4—{ Callect Payment ]—.O

va

C=-ed |

Post Office Officer

Requirements Gathering

Capturing the right requirements is the key in developing a system that can fully fulfill customer’s needs. Visual
Paradigm supports agile team in gathering requirements with use case and user story. Let’s see how the
requirements gathering features work.

Identifying Use Cases
A use case represents a high level function that yields a measurable result of values. Let’s see how to identify use
cases in use case diagram.

1. Create a new project first. You can create a new project by selecting Project > New from the toolbar. (We
will go back to QuickStart.vpp later on.)

2. Select UeXceler > UeXceler from the toolbar.

3. The User Story tab is opened by default. Now, open the Use Case Diagram tab.

Use Case Diagram Use Case User Story  Sprint
iy

4. Use the diagram editing tools and Resource Catalog to draw a use case diagram like this.

<<Case Story>>
Place Order
Customer
<<Case Story>>
Ship Orders
Seller
Writing User Story

Written by user(s) (or customer team), user stories describe functionality that are needed by and valuable to the
users. As an integral part of many agile development processes, user stories offer a quick way in recording user
requirements without the need to write any detailed requirement documents or to have any prior consideration of
system behaviors. Let’s see how to write user story in Visual Paradigm.

1. Open the User Story tab in UeXceler.

Use Case Diagram Use Case User Sﬁ:ry Sprint

2. Let’s say the system allows payment to be made by credit card. Let’s write a user story about that. Click
on + next to Place Order.

@ Place Order ;t\l
@ Ship Order +
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3. Astory card appears. Enter A customer can pay by credit card. Press Ctrl-Enter to confirm editing.
@ Place Order +

us0o1

A customer can pay by credit
card,

4. Create more user stories:
@ Place Order +

usoot usooz
A customer can pay by credit A customer can add remarls
card. to an order.
@ Ship Orders +
usoo3 Us004
A seller can see a list of A seller can post logistic
pending orders. details to an order to facilitate

order fracking.

Sprint Management
Customer team and development team work collaboratively to select the user stories to be included in the sprint
with a reasonable sprint duration. Let’s see how to manage sprint.

1. Open the Sprint tab.
2. Suppose the end user wants to have the core features available as soon as possible. Let’s create a sprint
that covers all those core features. Click on Add New Sprint.

+

Add New Sprint

¥

3. Enter Core Features as the name of the sprint.
Working «

Core Features|

Jan 8, 2016 - Feb 8, 2016
0 user story, O member

4. You can now add user stories into the sprint. Let’s say the following user stories are regarded as core
features by both the user. Press on them and drag them onto the pane on the right hand side.
a. Place Order - A customer can pay by credit card.
b. Ship Orders - A seller can see a list of pending orders.

Core Features [ one |

31} 2016-02-08

Y

General User Stories

= Place Order

A customer can pay by
credit card

Duser stories checked
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5. Click Done.

Core Features

31 ) 2016-02-08 0 user story, 0 member

A customer can pay by credit card.
Place Order

A seller can see a list of pending orders.
Ship Orders

Detailing User Story

User story is used as a reminder of conversation. During the conversation, discussions are made between the end
user and the development team to find out the details of user requirements. These details can include many things
like system flow, screen layout, etc. Let’s see how to detail a user story.

1. Inthe Sprint tab, double click on the user story A customer can pay by credit card to open it.

Sprint Core Features
Pending Usoo1w Pending Us003
A customer can pay by credit A seller can see a list of
card. pending orders.

2. Suppose the following items are determined during the discussions.
e  Support Visa, MasterCard, Discover and American Express
e Billing information required

o Surname

o Given name

o Address1

o Address 2 (optional)
e  Contact information required

o Telephone

o Email

Enter them as conversation notes under the Conversation tab. You can press Enter to create a new item,
and press Tab to add an indentation.

Conversation | Confirmation | Scenario | Storyboard | Design | References | Desaiption

® Support Visa, MasterCard, Discover and American Express
® Biling information required

® Surname

® Given name

® Address 1

® Address 2 (optional)
® Contact information required

® Telephone

® Email

3. Open the Confirmation tab to note down the item to be tested during user acceptance test.
e Test different card types — Visa, MasterCard, Discover and American Express
e Test with empty fields (make sure Address 2 is optional)

Test with expired card
e  Test with wrong CSC
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Conversation | Confirmation (0/4) | Scenario | Storyboard | Design | References | Description

[ ]| Test with different card types - Visa, MasterCard, Discover and American Express
[ ] | Test with empty fields (make sure Address 2 is optional)

[ ]| Test with expired card
O

Test with wrong S|

Writing User Story Scenario
Now, you have some conversation items collected from the end user. You can make use of these notes in forming
a standard user story scenario that describes the interactions between user and system.

1. Open the Scenario tab.

2. Enter the following steps as the scenario of this user story.
1. Click “Buy” in the shopping cart page.

Enter the credit card details.

Enter the billing information.

Enter the contact information.

Click “Pay”.

ukhwn

Conversation | Confirmation {0/4) | Scenario (1) | Storyboard | Design | References | Description

Click "Buy” in the shopping cart page.
Enter the credit card detalls,

Enter the biling information.

- Enter the contact information,

9 click "Pay" |

Scenario
1C

B W o

Scenario-based wireframing

Wireframe is a sketch of the system to be developed. We use wireframe to show users how the system will look
like, with minimal cost and effort. In Visual Paradigm, wireframe can be drawn and associated with scenario. Let’s
try.

1. Click onstep 1.
2. On the right hand side, click on the button that has a triangle on it.

Click "Buy" in the shapping cart page.
2. Enter the credit card details

3. Enter the biling information

4. Enter the contact information.

5. Click "Pay".

3. You see the gray pane appears on the right hand side? Click on it to select a kind of wireframe to create.

Click "Buy" In the shopping cart page.| [ ]
2. Enter the credit card details.
Enter the biling information,
4. Enter the contact information.
5. Click "Pay".

Click Here to Select

Wireframe
k

Extension:

4. Inthe popup window, select Website.
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5.

6.

Click New Website Wireframe.

Website

New Website Wireframe

A new wireframe appears with an empty browser window in it. Apply the diagramming techniques
described above to draw a wireframe like the following.

Shopping Cart X
(2] )
Commodity Product Information Unit Price Qty Subtotal
. | . | . |
]
. | . | . |
]
I | | | —
Go back to the scenario editor by clicking on the triangle button next to the step title.
1&1. Click "Buy" in the shopping cart page. (1)
[ |

Producing Requirement Specification

You can generate a functional specification for one use case which includes the details of its user stories such as
the conversation notes, confirmation items, scenarios, wireframe, etc. The end user can then verify the
specification to confirm the development plans. Let’s try.

1.

Open the Use Case tab in UeXceler.

Use Case Diagram  Use iﬁs: User Story  Sprint

Select the Place Order use case on the left hand side.

Place Order

Customer

Ship Orders
Seler

Select UeXceler > Use Case > Generate Requirement Spec from the toolbar.
This creates a requirement specification in Doc. Composer. Now, you may edit the document, click export

it into HTML/PDF/Word file by clicking on the Export button at the top right corner of Doc. Composer.
=E

HTML Document...

@ PDF Document...

ord Document...

That’s all for requirements gathering features. You can now open QuickStart.vpp and carry on with the
rest of this guide.
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Code Engineering

Java Round-Trip

= Round-trip engineering enables you to produce source code from UML model (and the other
%g ~ way round) and keep the source code and UML model synchronized. With Java round-trip,
AS you can generate Java source code from class model, or the reverse a Java code-base to class
diagram.

To generate Java source code from UML model:

1. Select Tools > Code > Generate Java Code... from the toolbar.
2. Edit the output folder in the Generate Code window.
3. Click OK to generate code.

To reverse engineer class model from Java source code:

Select Tools > Code > Reverse Java Code... from the toolbar.

Edit the source folder in the Reverse Code window.

Click OK to reverse code.

You can then create class diagram with the reversed classes. Simply open the Model Explorer to find the
classes and then drag them to class diagram to visualize them.

PwNE

C++ Round-Trip

== Round-trip engineering enables you to produce source code from UML model (and the other
%g = way round) and keep the source code and UML model synchronized. With C++ round-trip,
A you can generate C++ source code from class model or the reverse, a C++ code-base to class
diagram.

To generate C++ source code from UML model:

1. Select Tools > Code > Generate C++ Code... from the toolbar.
2. Edit the source and Cpp folder in the Generate Code window.
3. Click OK to generate code.

To reverse engineer class model from C++ source code:

Select Tools > Code Engineering > Reverse C++ Code... from the toolbar.

Edit the source and Cpp folder in the Reverse Code window.

Click OK to reverse code.

You can then create class diagram with the reversed classes. Simply open the Model Explorer to find the
classes and then drag them to class diagram to visualize them.

PwNE

Instant Reverse

Instant Reverse allows you to reverse different types of source into UML class models, such as Java, C++, CORBA,
Ada, PHP, Python, Objective-C, etc. To reverse, select Tools > Code > Instant Reverse....... from the toolbar, then
select the kind of programming language to reverse. Select the source files and proceed.

Instant Generator

Instant generator produces source code from your model at a particular instant. Unlike the code generation
support in round-trip engineering, instant generator is a one-off. To generate code, select Tools > Code > Instant
Generator... from the toolbar, then select the programming language in which to generate.

Page 19 of 31



Visual Paradigm Quick Start

Reverse Engineer Sequence Diagram from Java
Sequence diagram can help represent interactions between objects in runtime. Visual Paradigm enables you to

reverse your Java source code to sequence diagram. You can gain a better understanding of a piece of Java source
code by reading its corresponding diagram, instead of looking at possibly a thousand lines of code. To reverse Java
code to sequence diagram:

1.

Select Tools > Code > Instant Reverse Java to Sequence
Diagram... from the toolbar.

Add the folder that contains the source code. Click Next.
Expand the tree to select the class and its operation to
be reversed. Click Next.

In the Choose Diagram screen, select Create new
sequence diagram.

Click Finish

3 Instant Reverse Java to Sequence Diagram “

Select Operation

Select an operation to form a sequence diagram.

= [3y C:YeutputMyProjectisre
=2 ﬁ mypackage
@ ChequePayment.java

CreditCardPayment.java
\“;! Customer,java
H = E Customer

| g0 T
- @ Payment.java k

« Back Mext >

Cancel
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Documentation

Doc. Composer — Build from Scratch

Doc. Composer is a document creation tool. You develop a document by dragging a dropping templates to the
document editor, forming a complete document. The result can then be exported to MS Word, HTML and PDF file.

Customer

Use Case Diagraml

% Customer

ID: ACO1

®Place Order
ID: UCo1

®Edit Order

ID: uCoz

Cancel Order
ID: UC03

To use Doc. Composer:
1. Create a new document via the toolbar (Tools 4. The Template Pane is updated to list out the

> Doc. Composer).

available templates based on your selection.
2. Select Build Doc from Scratch.

Choose the appropriate template and drag it to

3. Selectin Diagram Navigator, Model Explorer the document editor.
or Class Repository the model Template T 8 x
element/diagram that you want to show in £ Loop
your document. "L/ Basic ’...-"'"" ~A
_/EDiagram M.. @ Model Exp.. 2 m,\\,’
Diagram Navigator S Y EProject Management
E‘[ %\ - @: B-a6- = References
ﬂQuickSTart - F= Use Case List

[J+{~5 UML Diagrams
BIE Use Case Diagram (1)

- 3 T
Class Diagram k

Sequence Diagram
-@Cﬂmmunicat’mn Diagri
-State Machine Diagrai

i [Z| Activity Diagram v
£ >

ﬁ Viewpaint

To export document as HTML/PDF/MS Word file, click on == at the top right corner of Doc.
Composer.
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Doc. Composer — Fill-in Doc

Fill-in Doc is a mode of Doc. Composer that helps you integrate design details into your project documentation. To
use Fill-in Doc:

1. Create a new document via the toolbar (Tools > Doc. Composer).
2. SelectFill-in Doc.

3. To make things simple, let’s try with a sample provided. Click on Software-Requirements-Specification.
¢ Specify Doc Base B

Data Specification Doc Template Details
Process Specification

File {.docx): Software-Reguirements-Specification.docx View

Mame: Software Requirements Specification

Description: Sample Doc Base of Software Requirements Specification

Created by: Visual Paradigm
Created at: Apr 15, 2015 12:00:00 AM

Choose from Local Drive OK Cancel

4. Click OK. You should be prompted for saving a Doc Base. A Doc Base is a semi-completed version of your
project documentation or report. It contains only background information, possibly filled by you or your
colleague. The design details are leave empty and be filled by Doc. Composer. Save it to somewhere in
your machine first.

5. Doc. Composer analyzes your Doc Base and presents the Doc Fields that exist in your document. Your
screen should look like this:

Doc Base: |C:\MyDocs\Software-Requirements-Specification. docx @ Open
Project Name &
Document Version
[
Use Case Diagrams = Diagram(3)  (UUseCaseDiagram) -a
Use Case Description
P
Use Ca.. (= Semens) ==& | [PROPERTY] description
[
Requirement Diagrams  [=3' DEgram(®)  (RequirementDiagram) =0
Requirement Description
P
Require.. | HSemenfs) =@ | [PROPERTY] description
Actor Description
P
Actors [ Bements) =@ [PROPERTY] description v
Preview Generate

6. Let’s take a look at the Doc Base first. Click Open.

(“3 Open %

~

7. You will see many variable-like fields throughout the document, like this:

Use Cases
${DIAGRAM, “Use Case Diagrams”, “UseCaseDiagram”, LoopInProject, “Basic™}
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Those fields are known as Doc Fields. A Doc Field is a special piece of text within a Doc Base. Doc Fields
will be replaced by your actual project content when being read by Doc. Composer during document

exporting.
8. Exit Microsoft Word and

go back to Visual Paradigm.

INSERT ~ DESIGN

~3j=] o =
HOME

Revision History.
Table of Contents
4 Introduction

4 Overall Description
Problem Statement
Background
Objectives
Constraints

4 Functional Requirements

4 UseCases
Use Case Diagram1
Requirements
User Requirements
4 Technical Requirements

Performance

PAGE5OF6 458WORDS [IR ENGLISH (UNITED STATES) &3

fillindoc5527554442080651467.docx [Compatibility Mode] - Word

PAGE LAYOUT REFERENCES MAILINGS REVIEW VIEW
i TimesNewRo-[13_-| A A Aa- % % -8 e
0 imes New Ro A A ] 2 2aBoCel 4aBbCel AaBbCel AaBbC
Paste. , B I U-asxx.x A-¥-A-BE - TCode-Se.. TComment TNormal TNo Spa
Clipboard & Font 5 Paragraph 5 styles
A i g 1 2 3 + s

Navigation e

Search document o~

HEADINGS. PAGES RESULTS

Gustomer

Use Case Diagram1

Use Case Description

?®m - 0 x
Sign in|
dHiFind -
T
| | #3cReplace
7R select-
© Ediing a
Aoz

Requirements

Now, click Preview to take a look at the end result. A temp. document will be produced, like this:

" 4 If you want to know more about Doc. Composer, click here to download the Doc. Composer

Writer’s Guide.

Project Publisher

Project Publisher helps produce Web contents from your project file.

g [ QuickStart

QuickStart

) Show All Diagrams

(5] Use Case Diagram
(3] Class Diagram
[l Seauence Diagram

[F1_Activitv Diaoram M

w

o

€« C' | [ file///C:/Users/Peter/Documents/Sample/index.html

QuickStart

Use Case Diagram - Use Case Diagram1

Jump to: | Please selacta model element ¥

P Use Case Diagram

[&3) Use Case Diagram1

Place Order
Customer
Cancel Order
Model Elements
Name Description

& Customer: Actor

@ Flace Order - Use Case
@ Edit Order : Use Case
@ Cancel Order ; Use Case

=2 link

QuickStart

To publish project with Project Publisher:

1. Select Tools > Publish Project... from the toolbar.
2. Inthe Project Publisher window, enter the output folder.

3. Click OK to start publishing.
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Collaborative Modeling

If you work as a team and need to work together on the same design, or to share your design with your
teammates, you need to make use of VPository.

VPository is the cloud-based repository where designs can be stored. You can upload your project to VPository and
allow your teammates to open and edit it.

Subscribing to VPository

In order to use VPository, you have to subscribe to it first. Subscription of VPository is made inside Visual
Paradigm. To subscribe to VPository for your team:

1. Select Team > Login from the toolbar of Visual Paradigm.

In the Teamwork Client window, click Subscribe to VPository... at bottom left.

3. You should see the VPository subscription page opened in your web browser. Enter your name, email
address and the cloud entry point. The cloud entry point is the unique URL of your VPository. Your team
will access the entry point to enter VPository for managing and opening the projects stored in VPository.

4. Read through the Terms of Service and Privacy Policy. Check | agree to VPository Teams of Service and
Privacy Policy if you agree to them.

5. Click Subscribe to VPository.

Getting Started

1 GB FREE storage, unlimited teammates,
unlimited projects

No credit card required.

Your Name: | Peter

Email: | peter@demo-vp.com

We will send confirm email to this email address.
And this email address will be manager login of this domain.

Cloud entry point: hltps:lf| demo .vpository.com

I agree to VPository Terms of Service and Privacy Policy.

6. Check your Email client. You should receive an Email with VPository subscription confirmation as the

subject.
7. Click on the hyperlink Confirm your VPository Subscription in the Email.
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8.

9.

10.

11.

12.
13.
14.

15.

16.

This opens another web page, asking you for details about the repository and you, the manager of the
VPository account. Enter the information and click Start My VPository.

Repository
Cloud entry point:  https://demo.freshofall.com/
Name: Visual Paradigm Demo ?
Manager
Email: peter@demo-vp.com
Name: ‘ Peter ‘
Password: ‘ 0003540000000 00000 ‘

Quality: Y uulENE Average

Confirm Password: ‘ sssssssscscesssssse ‘

You've finished subscribing to VPository. Now, go back to Visual Paradigm. You should see that the login
details have been filled for you automatically.

CollaborativeVista eling form.in the Cloud
Cloud entry point: https:// demo .vpository.com
Email peter@demo-vp.com
Password: 0000000000000 0000000

Remember password

Click Login. Because your VPository is newly setup, you are suggested to create a project in it. Just click OK
to continue.

This shows the Import Project to VPository screen. If you are opening the Quick Start project, the option
Currently Opened Project should be selected for Import from. Just keep it selected. In practice, you can
change to import a new project or to import an existing .vpp project file to VPository.

Import from: |}
Name: QuickStart
Author: Peter

Data type set: | UML
At the bottom of the window, click Add Project Member.
Let’s invite your teammate to work on this project. Click Invite New Member... at the bottom.
Enter the name and Email address of your teammate and click OK.

MName Email

Mary mary @demo-vp.com +

Click Import. Invitees will receive invitation Emails. By accepting the invitation, they can login VPository
from Visual Paradigm, with the cloud entry point and their own password (provided during the
acceptance of invitation).

Click Open at the bottom right of the Teamwork Client window to open the imported project.
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Importing a Project
To import a new project to server:

Select Team > Utilities > Open Teamwork Client from the toolbar of Visual Paradigm.

In the Teamwork Client window, select Project > Import Project to Repository from its menu.
Specify the project source in the Import from field, edit the project name, author and description.
Invite your teammate(s) by clicking Add Project Member at the bottom of the window.

Click Import.

ok wNRE

Committing

Commit is the process of uploading changes made in the working copy back to server. When you, one of the team
members, make changes in a project, you can share your works by committing those changes to the VPository and
let others to update the changes from VPository.

To commit changes:

1. Select Team > Commit from the toolbar.
2. Review the changes in the Commit window, which involves both the changes you made and the changes
made by others and will be updated to your project.

<« Commit “
Fiter: | Commit and Update
Diagrams * | Model Elements * | Nicknames | Files | Changes ®
R
[%]Use Case Diagram1 ocal change
&) Cancel Order
- [ERegistration
[ Zparcel Collection payments  EEEa MaTIEES
= 1T
&) Domain el o e
= =
Open Specification
Name (Local modified)
Local change: | Account
Original value: |customer
3. Click Commit.
" 4 When finish committing, the changes you made will be uploaded to server and at the same time,

latest changes in server are updated to your local project copy.

Updating
Update is the process of refreshing the working copy by merging changes that others have made and committed to
server.

To update changes from VPository:

1. Select Team > Update from the toolbar.
2. Review the changes in the Update window.
3. Click Update.
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Sharing Your Design with PostMania

When you finish your design, you might want to share it with someone in order to ask him/her for verification,
approval or take certain action based on your design (e.g. to execute a process plan modeled with a BPD). In Visual
Paradigm, an effective way to share your design is by using PostMania.

PostMania is a tool built into VPository. It allows you to share your design with someone. It also allows the reader
known as a “viewer” in PostMania to share his comments with you.

Sharing Diagram
To share your design with PostMania:

1. Open the diagram you want to share with others.
2. Open the PostMania Topic Pane by opening the action bar. Click on the tiny button on the right hand side
of the diagram to open the action bar.

3. Select PostMania Topic Pane from the action bar.

||
™
L
4. Click on the Share button at the top of the PostMania Topic Pane.
PostMania Topics -@l

5. Inthe Share Diagram window, enter the name and Email address of the people to share with.
¢ Share Diagram B

Share diagram with someone else

Share this diagram with someone, say your dient, stakeholder, teammate, or whomever.
Allow him/her to view the diagram online and give you some feedback. By supplying their
name and email addresses below, we will send them invitation email, inviting them to join
PostMania for viewing and commenting diagrams.

People to invite
victor victor@demo-vp.com|

[[] Invitation Note
[] viewer List
[ 5hare by Link

Bulk Share Send Invitation Email Cancel

6. Click Send Invitation Email. In order for these people to view the shared diagram, they have to join
PostMania. Here we are going to send them invitation Emails.

Invitation Emails will be sent out in three minutes. Invitees can then accept the invitation to join PostMania. After
that, they can view the diagram you shared in web browser. They can also post comments to diagrams, to shapes
or to properties like description, flow of events (for use case), etc.
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@) PostMania New Post
& - @ |[) demo.vpository.com/postmaniajsp#did | I Subject
I N I "Collect Payment" is redundant

Enter Message

We only accept "Pay in advance”. Please
remove this act\wtyT

3
§
!
g

&

Reacting to Comments
When a viewer has posted a comment, as a member, you will see a notification in status bar, like this:

LA

Click on it to open PostMania. Notifications are listed on the left hand side. Click on a notification to view its detail.

"Collect Payment” is redundant

We only accept Pay in advance . Please remove & act

!.:::' G)_ @:

By clicking on a notification you can see the unread conversation listed on screen. You can give a quick reply at the
bottom of the screen, or click Open at the top right corner to open the related diagram.

"Collect Payment" is redundant open [

Collect Payment

DESCRIPTION

Victor 2mins

We only accept Pay in advance™, Please remove this activity.

If you click Open, the related diagram will be opened, with highlight to the discussed area. You can then refine the
design based on client’s request, commit the change and add a reply in the PostMania Topic Pane to ask the
viewer to verify the change.

4 "Colect Payment" is redundant

We only accept "Pay in advance”.
Callect Payment Please remove this activity.

L] ] 2 o ®
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Advanced Modeling

Nickname

If you are working in or working for multinational corporations, you may need to maintain your model in multiple
languages. The Nickname feature helps you achieve that. It allows you to maintain multiple languages in one single
project without the need to keep multiple project files for same content.

=
Customer K
Cancel Order HUHETEL

To add a new language:

Select Modeling > Nickname > Configure Nicknames... from the toolbar.

In the Configure Nickname window, click Add User Language....

In the Add User Language window, select the language to add.

The newly added language is selected in the Configure Nicknames window. Keep it selected and click OK.
Now, you can rename the shapes and diagrams to “translate” the model to the language added. To switch
the model back to the original language, select Modeling > Nickname > Original from the toolbar.

e wNR

Project Reference

To avoid creating the same things (e.g. a class) over and over again, it would be useful to have a generic library to
keep components for reuse. When you make any changes to the components in the library, those changes will
ripple down to where the components are actually used. In Visual Paradigm, we call this generic library a
“Reference Project”. To add project reference and re-use the data in referenced project:

Select Project > Referenced Projects from the toolbar.

In the Manage Referenced Projects window, click Add.

Choose the .vpp project file to reference to and click Open.

Close the Manage Referenced Projects window by clicking Close.

Open the Model Explorer. The referenced project(s) are listed in the drop down menu at the top of the
Model Explorer. You can switch between the current project and the referenced project through the drop
down menu to see the elements in them.

LA o

Model Explorer o & X
E,

T E1ﬂ = lﬁ A ] @

MyGenericProject.vpp W

QuickStart(Current)

=T

List Referenced Model Elemant/Shap

£} Externalizable
+- (& ObjectInput
+}- [E] ObjectOutput
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6. You can re-use a model element from referenced project by drag-and-drop.

Model Explorer o B X # (Class Diagram1
=, ~,
o - E-'j A -2 <default package > | o
MyGenericProject w r'S
__|MyGenericProject E
=-figib 4
1 i "
el P et P
[ e
Externalizabl —
ﬁ x. rnalizable > |+read({Objectinput in)
ﬁ Objectinput |+write(ObjectOutput out)
[E objectoutput * "

7. You can connect referenced project data with the data of the current editing project.

<<Interface>>

Externalizable
[+read(Objectinput in)
+write(ObjectOutput out)

A

payments

+printC D : String)

1.7

-date : Date
-remarks : String

CreditCardF

ChequeF
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Impact Analysis

If you want to make a change to some model elements, it would be important to know which other elements will
get affected because of it. Impact Analysis can help you with that.

Matrix Diagram
Matrix Diagram helps you to identify the relationship between model elements of specific type(s), so as to study
the consequence of making certain changes. To create a matrix:

1. Create a matrix by selecting Modeling > Impact Analysis > Matrix from the toolbar.
Let’s say if you want to inspect the relationship among all the classes in the project. Add class to both
Models on Row and Models on Column by first selecting class on the left hand side and clicking > to add
it into row and column list respectively.

3. Select Relationship for By. By here means to compare row and column items by the selected criterion.

Diagram Name: Matrix Diagram1
Scope: @ Project () Disgrams () Model Package
Template: (None) v

Available Models Matrix Diagram

2 Actor Models an Row
B css
8] Model ?»
e} stereotype <
@ Use Case
[ UserStory
.3
Models on Cokmn
(B cless
?
<

By: [Relationship v | [

Relationship: () v
Relationship Stereotype: (A

Indude chidren: O

Indude non-master view chidren:

4. Click OK. This produces a matrix which lists the classes in rows and columns, showing their relationships in

cells.

Sort:| Name w | Show rows/columns:| Matches only w | [filter row... # (filter column,.. |4

(4) Class

By: Relationship w u

Relationship:| (All) Y] = E

Relationship Stereotype:| (All) « % é‘

Include children: [] % § E Z

B > 5|88 &

Include non-master view childreri: < S|ls|l 3| =

(4) Class AV ﬂmﬂmﬂmﬂm

E CheguePayment —

E CreditCardPayment —

E Customer —

E Payment G— E —

|Genera|ization (CreditCardPayment <-> Pa)rment]|

Let’s say you are thinking about deleting the Payment class. By reading the matrix, you realize that the
Payment class is a super class of CreditCardPayment and ChequePayment. Deleting the super class
Payment may risk losing data. So you’d probably need to consider withdrawing the deletion or to move
the data from super class to sub class, etc.
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